Горячая вакансия: PCB engineer 80000 КА Работа
Я ищу работу в IT сфере ✈ Я ищу резюме в IT сфере ✈

Быстрая публикация IT события здесь

Найдена уязвимость, позволяющая «превратить» Windows XP в Windows Embedded POSReady

В реестре Windows XP обнаружена уязвимость, заставляющая Центр обновлений Windows «поверить», что компьютер работает под управлением встраиваемой системы Windows Embedded POSReady. Таким образом пользователи Windows XP могут продолжить получать обновления безопасности, несмотря на то, что Microsoft прекратила выпуск обновлений для Windows XP.


Ресурс Betanews опубликовал инструкцию, позволяющую настроить реестр Windows XP таким образом, чтобы Центр обновлений полагал, что компьютер работает не под Windows XP, поддержка которой к настоящему моменту прекращена, а под управлением успешно обновляющейся ОС Windows Embedded POSReady. Windows Embedded POSReady 2009 представляет собой встраиваемую версию Windows для электронных платежных терминалов (point-of-service, POS). В отличие от Windows XP, она является поддерживаемым продуктом Microsoft и будет получать обновления безопасности еще пять лет - до 9 апреля 2019 г. Для того чтобы использовать уязвимость, пользователю необходимо создать файл с расширением .reg и следующим содержанием:

Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SYSTEM\WPA\PosReady] "Installed"=dword:00000001

После этого необходимо сохранить и запустить файл двойным кликом в Windows Explorer. Редактор реестра внесет изменения, после чего, открыв Центр обновлений Windows, пользователь сможет обнаружить несколько свежих обновлений.
При установке обновлений нужно быть очень внимательным: некоторые из них, отмеченные как «WEPOS» или «POSReady 2009» — это специфические обновления для Windows Embedded POSReady. Однако, Центр обновлений также предложит несколько обновлений, подходящих для Windows Server 2003, которая базируется на том же ядре и компонентах, что и Windows XP, и их, без сомнений, можно установить без всякого риска.
Этот специфический «хак» работает только для 32-битных систем. На 64-битную Windows XP обновления Windows Server 2003 не установятся.
Корпорация Microsoft отреагировала на найденную уязвимость, выпустив официальное сообщение: «Недавно нам стало известно об уязвимости, обход которой позволяет пользователям Windows XP получать обновления безопасности. Обновления безопасности, которые предлагаются к установке, предназначены для Windows Embedded и Windows Server 2003, и не могут полностью защитить Windows XP. Установка данных обновлений также подвергает пользователей Windows XP риску нарушения функциональности компьютера, поскольку они не тестировались на Windows XP. Лучшим способом защитить свои системы для пользователей Windows XP является обновление до современной операционной системы, такой как Windows 7 или Windows 8.1.»
➥ ✈

Поиск IT персонала. Давайте решать задачи вместе! rabota@rabota-ka.ru



HotLog Rambler's Top100 Яндекс.Метрика
Отправить комментарий
Яндекс.Метрика Яндекс цитирования

Сообщения на Email